Impact from Cloudflare Global Network Issues
Resolved·Partial outage

This incident has been resolved. The root cause was fixed, and the resolution was deployed. Thank you for your patience.

Tue, Nov 18, 2025, 10:14 PM
(3 weeks ago)
·
Affected components
Updates

Resolved

This incident has been resolved. The root cause was fixed, and the resolution was deployed. Thank you for your patience.

Tue, Nov 18, 2025, 10:14 PM

Investigating

We are currently investigating reports of widespread issues affecting our platform. The preliminary investigation indicates that this outage is due to a major, global disruption impacting the Cloudflare network, which serves as a critical infrastructure provider for our services.

  • Impact: Customers may be experiencing intermittent or total failure accessing our website, API, and associated services, often seeing a "500 Internal Server Error".

  • Root Cause: External dependency failure (Cloudflare Global Network).

  • Current Action: Our team is actively monitoring the Cloudflare status page and exploring potential workarounds for any impacted services.

We will provide an update as soon as Cloudflare reports progress on their resolution or when we have more details on the path to recovery.

Tue, Nov 18, 2025, 02:59 PM(7 hours earlier)