Major Service Disruption - US Region
Resolved·Partial outage

All services are back to normal. Our team is investigating if there are any issues.

Tue, Oct 21, 2025, 02:43 AM
(1 month ago)
·
Affected components
Updates

Resolved

All services are back to normal. Our team is investigating if there are any issues.

Tue, Oct 21, 2025, 02:43 AM

Investigating

We’ll provide an update as soon as more information becomes available.

Mon, Oct 20, 2025, 11:40 PM(3 hours earlier)

Investigating

We are currently experiencing elevated error rates from our cloud provider’s API, which is impacting availability and performance for our Interviewer and related Platform services. Our engineering team is actively monitoring the situation to mitigate the issue.

We will continue to provide updates as more information becomes available or once the incident is resolved.

Mon, Oct 20, 2025, 02:11 PM(9 hours earlier)